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Getting Started with P4V
P4V is Perforce’s cross-platform graphical user interface. You can use P4V on Windows, 
Macintosh, UNIX and Linux computers and benefit from a consistent approach regardless 
of platform. This introductory guide provides some Perforce basics and an orientation to 
P4V’s layout and features. For more details about P4V, consult its online help. To learn 
more about Perforce, consult the user documentation on our Web site.

To use Perforce to manage files, you typically connect to a server using a client program 
like P4V. P4V enables you to check files in and out, and perform the various other 
necessary tasks. The following sections tell you how to perform these tasks and point out 
powerful features and shortcuts.
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Basic Concepts
Basic Concepts

P4V connects your computer to a Perforce server to move files between Perforce depots and 
your workspace, as shown below.

The precise definitions for these Perforce terms are as follows:

• depot: a file repository on the Perforce server. It contains all existing versions of all files 
ever submitted to the server. There can be multiple depots on a single server. The 
examples in this guide show a single depot.

• server: the program that executes the commands sent by client programs, maintains 
depot files, and tracks the state of workspaces.

• workspace: folders on the client computer where you work on revisions of files that are 
managed by Perforce. 

Workspace P4V Server Depot

Workspaces store 
local copies of files 
on...

...your computer, 
running P4V, which 
connects to...

...the Perforce Server, 
which manages...

...depots, repositories 
of files under 
Perforce control
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Connecting to a Server
Connecting to a Server

To gain access to your depots, you must connect to a server. To connect to a server:

1. Launch P4V. P4V displays the following connection dialog:

2. Specify the following settings (your Perforce administrator can provide you with this 
information)

• Server: the name of the computer where your Perforce server is running.

• Port: the port number assigned to the server

• User: your Perforce user name

• Workspace: the name of your client workspace.

To display a list of existing users and workspaces for a (correctly) specified server, 
click Browse. 
Getting Started with P4V 7



Connecting to a Server
If you have incorrectly specified a server setting, P4V displays a message like the 
following:

3. To connect, click OK. P4V displays its main screen, as shown in the following figure.

The next section describes the main screen panes.

Connect to server failed; check $P4PORT.

TCP connect to bigserver failed.

bigserver: host unknown.
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Navigating the Main Screen
Navigating the Main Screen

The following figure points out the panes and important features of the main screen. To see 
what a button or screen element does, hold the mouse cursor over it. P4V displays a 
descriptive tooltip.

Left pane: displays files 
and folders. The depot tab 
displays files in the 
Perforce server, and the 
workspace pane displays 
files in the workspace on 
your computer

Right pane: displays Perforce 
specifications and file 
information. To select the 
specification you want to display, 
choose View or click the 
corresponding toolbar button.

Log pane: displays the Perforce commands that P4V issues, 
plus error messages and results.
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Managing your Files
Managing your Files

To manage files using Perforce, you typically perform the following tasks:

1. Set up your workspace.

2. Get files from the depot.

3. Check out files you need to edit.

4. Edit files.

5. Check in your changes.

The following sections provide details about these and other common file management 
tasks.

Setting up your workspace

Your Perforce administrator can do this for you, but it’s advisable to learn a few important 
aspects of configuring your workspace, specifically (1) configuring the client root 
directory and (2) configuring the client view.

To display your workspace specification, choose View > Client Workspaces or click . 
P4V displays a list of workspaces in the right pane. To edit your workspace specification, 
click it. P4V displays details in the bottom of the right pane. To make changes, click 

. 
10 Getting Started with P4V



Managing your Files
P4V displays the specification details in the lower right portion of the right pane; for 
example:

Client root: specifies the location on 
your computer under which Perforce 
stores copies of depot files. Specify a 
meaningful name, and make sure it’s 
not set to your computer’s root 
directory!

Client view: enables you to restrict 
the depot files to which you have 
access. Set the client view to ensure 
that you see only what you need to 
see.

Client 
specification: 
enables you to 
define a workspace 
and specify its 
settings.
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Managing your Files
To display and set the client view graphically, click the View tab. Browse to desired files 
and folders and context-click to include them or exclude them from the client view, as 
shown in the following figure.

Click Save to save changes. Click the “x” to dismiss the Workspace specification 
list.
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Managing your Files
Getting files from the depot

To copy files from the depot to your workspace:

1. In the left pane, click the Depot tab.

2. Browse to the folder or file you want to retrieve.

3. Context-click the file or folder. To get the most recent version, choose Get Latest 
Revision. To get an older version, choose Get Revision... and specify the version you 
want. 

In the Log pane, P4V displays a message like the following.

In the left pane, note that the file displays a green dot, indicating that it is present in your 
workspace:

Now the file resides in your workspace, and you can view it. But if you want to edit the 
file, you must first check it out.

Checking out files from the depot

To check out a file in your workspace:

1. Browse to the desired file in the left pane Depot tab. 

2. Context-click the file and choose Open for Edit.

In the Log pane, P4V displays a message like the following:

In the left pane, note that the file displays a red check mark, indicating that you checked it 

out:

Note that, when you check out a file, Perforce adds it to a changelist, which is a list of 
related files. You can use changelists to group related files, for example, all files that 
contain changes required to implement a new product feature. To view the changelist, 

choose View > Pending Changelists or click .

Now you’re ready to make changes.

p4 sync //my-test-workspace/main/bark

//depot/main/bark#2 - added as c:\p4clients\my-test-workspace\main\bark

sync complete. 1 file affected.

p4 edit //my-test-workspace/main/bark

//depot/main/bark#2 - opened for edit
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Managing your Files
Editing files in your workspace

To edit a checked-out file, double-click it. P4V launches the corresponding editing 
application. Make changes and save the file.

Note that you can configure editors for different file types by choosing Tools > 
Preferences... and clicking the Editors tab. 

Diffing files to view your edits

To enable you to see what changes you’ve made, you can compare (diff) your edited file 
with the version you checked out. To diff, context-click the checked-out file in the left 
pane and choose Diff against Revision. P4V launches P4Diff, displaying the differences 
between the two files. For example:

Discarding edits by reverting

If you decide you want to discard your changes:

1. Context-click the file in the left pane and choose Revert Files. P4V displays a 
warning dialog. 

2. Click OK. In the Log pane, P4V displays a message like the following:

p4 revert //my-test-workspace/main/bark

revert complete. 1 file affected.
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Managing your Files
Checking your edits into the depot

To check your changed file into the depot, perform the following steps.

1. Display pending changelists: click . P4V displays a list of pending changelists, as 
shown in the following figure.

2. Double-click the changelist in which your file is open. P4V displays the details, as 
shown in the following figure.
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Managing your Files
3. Enter a description explaining the changes you made and click Submit. The Log 
pane displays a message confirming that your changelist was submitted, similar to 
the following.

Change 7941 submitted.

    submit complete. 1 file affected.
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Graphical Reporting Tools
Graphical Reporting Tools

P4V includes several valuable graphical reporting tools:

• Revision Graph: displays a diagram that shows the evolution of a selected file, 
including files related by branching operations.

• Time-lapse View: shows how the contents of a selected text file changed from revision 
to revision. You can easily sweep through revision ranges to locate passages of interest 
and see when they were created and how they changed.

• Folder diff tool: enables you to see how the contents of a folder changed.

The following sections provide more details about these tools.

Revision Graph

To display the revision diagram for a file, context-click the file in the left pane and choose 
Revision Graph. P4V launches the tool, which displays a diagram like the following one.

This diagram shows you when the file was created, how it was branched, and enables you 
to view details about each version submitted to the depot. For more details about the 
information displayed in the revision graph, consult P4V online help.
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Graphical Reporting Tools
Time-lapse View

To browse the changes made to a text file, context-click the file in the left pane and choose 
Time-lapse View. P4V launches the utility, which displays a screen like the following one. 

Using Time-lapse View, you can sweep through all revisions of the file in a single 
window, noting when changes were made and who made them. Again, for details, 
consult P4V online help.

Folder diff tool

The folder diff tool enables you to see how the contents of a folder have changed: which 
files are added, changed, or deleted. To view changes to a folder:
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Graphical Reporting Tools
1. Context-click lick the folder in the right pane Depot or Workspace tab and choose 
Folder History. In the right pane, P4V lists changelists that affected the folder, for 
example:

2. To display the changes that occurred between to changelists, drag one of the 
revisions of interest to the other. 

P4V displays a diff showing the changes. Expand folders and scroll to locate changes of 
interest. The following example shows that, between the selected revisions, a file was 
edited and checked in.
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Important and Useful Features
Important and Useful Features

Among the many features provided by P4V, the following are especially useful:

• Tooltips: to get more information about an object, place your mouse cursor over it. P4V 
displays a popup dialog containing more details.

• Drag and drop: P4V includes numerous drag and drop shortcuts for common 
operations.

• File views: P4V enables you to preview graphics files using thumbnails.

• Tear off windows: to create a separate window displaying a specification you want to 
keep on display, you can tear it off.

The following sections provide more details.

Tooltips

P4V provides tooltips for many objects on the screen. For example, to display the status of 
a file, hold the mouse cursor over the file in the left pane. P4V displays a tooltip like the 
following one.

To display a changelist description, click and hold the mouse cursor over the 
changelist in the right pane. There are tooltips for all the P4V buttons, too.

Drag and drop

P4V provides drag and drop shortcuts for common tasks. Drag and drop can simplify 
operations on large groups of files. For example, to check out all the files in a folder, drag 
the folder to a changelist. To diff two files, drag one to the other. To add a file, drag it from 
the operating system explorer or Finder to a changelist. For details about drag and drop 
shortcuts, refer to the P4V online help.
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Important and Useful Features
File views

If you user Perforce to manage graphics files, P4V’s thumbnail views enable you to 
preview the files. To display thumbnails, click the Files tab in the right pane, then select 
the desired thumbnail size:

P4V displays thumbnails as shown in the following example.

Tear off

To keep a specification on display in a separate windows while working with the 

specifications, you can tear it off or undock it. For example, click  to display submitted 
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Important and Useful Features
changelists, select a changelist, then choose Window > Undock Tab. P4V opens a separate 
window for it, as shown in the following figure.

To restore it to the main window, choose Window > Dock Window.

Setting Preferences

To configure P4V, choose Tools > Preferences. The tabbed Preferences dialog is 
displayed. In particular, the Editor tab enables you to associate applications with file 
types, overriding any operating system associations. The Diff and Merge tabs enable you 
to configure external applications, in case you prefer tools other than those that are 
bundled with P4V.
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Next Steps
Next Steps 

This guide enables you to start working with files using P4V and points out important 
basic features, but P4V enables you to do much more: create jobs, branch groups of files, 
and handle file conflicts that arise in team development settings. However, there are 
limits to what you can do with P4V: there is a set of administrative functions that P4V 
does not support. These administrative tasks are done using the Perforce command-line 
client (p4). For details, see the Perforce Command Reference.

To become expert with P4V:

• Consult the P4V online help and read the Perforce user documentation available from 
the Perforce Web site.

• Use tooltips.

• In the left pane, pay attention to the file icon decorations, which display a great deal of 
information about the status of a file. 

• Watch the Log pane.

• Learn drag and drop shortcuts to simplify operations on large sets of files.

• Use P4V views and filtering features to enable you to selectively display information.

To get the whole picture, read the Perforce User’s Guide and the Perforce System 
Administrator’s Guide. These documents, which are available from the Perforce web site, 
describe the full set of features that the Perforce Server provides. 
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Next Steps
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