WebBrowserPassView

WebBrowserPassView v1.25
Copyright (c) 2011 - 2012 Nir Sofer
Web site: http://www.nirsoft.net

Description

WebBrowserPassView is a password recovery tool that reveals the passwords stored by the following Web browsers: Internet Explorer (Version 4.0 - 9.0), Mozilla Firefox (All Versions), Google Chrome, Safari, and Opera. This tool can be used to recover your lost/forgotten password of any Website, including popular Web sites, like Facebook, Yahoo, Google, and GMail, as long as the password is stored by your Web Browser.

After retrieving your lost passwords, you can save them into text/html/csv/xml file, by using the 'Save Selected Items' option (Ctrl+S).

System Requirements And Limitations

  • This utility works on any version of Windows, starting from Windows 2000, and up to Windows 7, including 64-bit systems. Older versions of Windows (Windows 98/ME) are not supported, because this utility is a Unicode application.
  • Currently, WebBrowserPassView cannot retrieve the passwords if they are encrypted with a master password. Support for master password will probably be added in future versions.
  • Currently, WebBrowserPassView cannot retrieve passwords from external hard-drive. Support for that might be added in future versions.
  • On Internet Explorer 7.0-9.0, the passwords are encrypted with the URL of the Web site, so WebBrowserPassView uses the history file of Internet Explorer to decrypt the passwords. If you clear the history of Internet Explorer, WebBrowserPassView won't be able to decrypt the passwords.
  • On Google Chrome - passwords originally imported from Internet Explorer 7.0-9.0, cannot be decrypted.

Versions History

  • Version 1.25:
    • Added 'User Name Field' and 'Password Field' columns for Chrome, Firefox, and Opera Web browsers.
  • Version 1.20:
    • Added 'Password Strength' column, which calculates the strength of the password and displays it as Very Weak, Weak, Medium, Strong, or Very Strong.
  • Version 1.15:
    • Added support for Safari Web browser (passwords are decrypted from keychain.plist)
  • Version 1.12:
    • WebBrowserPassView now automatically extracts the passwords of Chrome Canary.
  • Version 1.11:
    • The passwords of Chrome Web browser are now displayed properly even when the password file is locked by Chrome.
  • Version 1.10:
    • Added option to choose the desired Opera password file (wand.dat).
    • Imporved the detection of Opera password file (wand.dat).
  • Version 1.05:
    • Added new options for Firefox passwords: Use a master password to decrypt the passwords, Load the passwords from the specified profile folder, and the option to use the specified Firefox installation.
    • Added option specify the profile folder (User Data) of Google Chrome (For example: C:\Documents and Settings\Administrator\Local Settings\Application Data\Google\Chrome\User Data\Default)
      Be aware that this feature only works if the profile was created by the current logged on user. Loading from external drive is not supported yet.
  • Version 1.00 - First release.

Using WebBrowserPassView

WebBrowserPassView doesn't require any installation process or additional DLL files. In order to start using it, simply run the executable file - WebBrowserPassView.exe

After running it, the main window of WebBrowserPassView displays the list of all Web browser passwords found in your system. You can select one or more passwords and then copy the list to the clipboard (Ctrl+C) or export them into text/xml/html/csv file (Ctrl+S).

False Virus/Trojan Warning

WebBrowserPassView is a tool that retrieves secret passwords stored in your system, and thus your Antivirus may falsely detect this tool is infected with Trojan/Virus. Click here to read more about false alerts in Antivirus programs.

Command-Line Options

/stext <Filename> | Save the passwords list into a regular text file.
/stab <Filename> | Save the passwords list into a tab-delimited text file.
/scomma <Filename> | Save the passwords list into a comma-delimited text file (csv).
/stabular <Filename> | Save the passwords list into a tabular text file.
/shtml <Filename> | Save the passwords list into HTML file (Horizontal).
/sverhtml <Filename> | Save the passwords list into HTML file (Vertical).
/sxml <Filename> | Save the passwords list into XML file.
/skeepass <Filename> | Save the passwords list into csv file that can be imported into KeePass Password Manager.
/sort <column> | This command-line option can be used with other save options for sorting by the desired column. If you don't specify this option, the list is sorted according to the last sort that you made from the user interface. The <column> parameter can specify the column index (0 for the first column, 1 for the second column, and so on) or the name of the column, like "URL" and "Web Browser". You can specify the '~' prefix character (e.g: "~Web Browser") if you want to sort in descending order. You can put multiple /sort in the command-line if you want to sort by multiple columns. Examples: WebBrowserPassView.exe /shtml "f:\temp\passwords.html" /sort 2 /sort ~1 WebBrowserPassView.exe /shtml "f:\temp\passwords.html" /sort "Web Browser" /sort "URL"
/nosort | When you specify this command-line option, the list will be saved without any sorting.

Translating WebBrowserPassView to other languages

In order to translate WebBrowserPassView to other language, follow the instructions below:
  1. Run WebBrowserPassView with /savelangfile parameter:
    WebBrowserPassView.exe /savelangfile
    A file named WebBrowserPassView_lng.ini will be created in the folder of WebBrowserPassView utility.
  2. Open the created language file in Notepad or in any other text editor.
  3. Translate all string entries to the desired language. Optionally, you can also add your name and/or a link to your Web site. (TranslatorName and TranslatorURL values) If you add this information, it'll be used in the 'About' window.
  4. After you finish the translation, Run WebBrowserPassView, and all translated strings will be loaded from the language file.
    If you want to run WebBrowserPassView without the translation, simply rename the language file, or move it to another folder.

License

This utility is released as freeware. You are allowed to freely use it at your home or in your company. However, you are not allowed to make profit from this software or to charge your customers for recovering their passwords with this software, unless you got a permission from the software author.
You are also allowed to freely distribute this utility via floppy disk, CD-ROM, Internet, or in any other way, as long as you don't charge anything for this. If you distribute this utility, you must include all files in the distribution package, without any modification !

Disclaimer

The software is provided "AS IS" without any warranty, either expressed or implied, including, but not limited to, the implied warranties of merchantability and fitness for a particular purpose. The author will not be liable for any special, incidental, consequential or indirect damages due to loss of data or any other reason.

Feedback

If you have any problem, suggestion, comment, or you found a bug in my utility, you can send a message to nirsofer@yahoo.com